When using JoinXR, if you find that no one can hear you, and dictation doesn't work, troubleshoot the following options to identify and resolve the problem
Check Microphone Permissions
Platforms
- HoloLens 2
- Meta Quest 2/3/Pro
Symptoms
- When you start the app "Microphone permissions denied. Please check your privacy settings" is shown
- You see this message "Failed to initialize dictation" when starting a dictation
Cause
When you first install JoinXR you will be prompted to give the app permission to use your microphone. If you choose no or accidentally dismiss the prompt this will prevent JoinXR from accessing the microphone.
Solution
The solution to this varies depending on the platform you're on
HoloLens 2
1. Open the start menu
2. Tap Settings
3. Then select Apps
4. Scroll to find, select JoinXR and then tap Advanced Settings
5. Make sure the Microphone permissions are enabled
Quest 2/Pro
1. Find JoinXR in your app library
2. Select the three-dot icon to open the app menu.
3. Select permissions from the drop-down menu that appears.
4. Select Allow Microphone Permissions.
Microphone Muted in the OS
Platform
- Meta Quest 2/3/Pro
Symptoms
- No one can hear you, but no error message is shown
- Dictation doesn't work, but no error message is shown
Cause
- Some headsets let you mute the microphone at the OS level, preventing JoinXR from receiving any microphone input.
- There is a known bug in the Quest OS which can cause your mic to be muted in the OS when you take the headset on and off.
Solution
Meta Quest 2/3/Pro
- Press
on your right Touch controller to pull up your universal menu.
- Hover over the clock on the left-hand side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
- Select
to unmute the microphone.
JoinXR Desktop app using the wrong microphone
Symptoms
- Remote users say you are too quiet or are picking up a lot of background noise
Cause
- If you have multiple microphones connected to your computer JoinXR will pick one as your default microphone, this may not match up with other applications you're using so results in poor quality microphone audio.
Solution
You can manually select which microphone you want JoinXR to use.
- In JoinXR Desktop, when connected to the meeting choose "Settings"
- In the settings menu, you will see a drop-down for microphones.
- Select which microphone you would like JoinXR to use